UPDATE:
03/15/2026 02:30 AM MDT - UTOPIA has informed us that this outage has been resolved.
UPDATES:
03/14/2026 10:59 PM MDT - Fiber line fell and it appears someone cut it. Fiber splice is pending.
UPDATE:
UTOPIA has found the fiber cut and is in the process of repairing it. ETR remains unknown
UPDATE:
DESCRIPTION: UTOPIA Network Outage Possible fiber damage. Listed customers may not match as most affected customers are on ADS-5001 which doesnt match documentation.
CATEGORY:
START TIME: 03/14/2026 08:25 PM MDT
END TIME:
SCOPE OF IMPACT: Customers affected may be without service.
VERIFIED BUSINESS/ENTERPRISE CUSTOMERS: 0
VERIFIED RESIDENTIAL CUSTOMERS: 13
UTOPIA has made us aware of an outage affecting customers in West Valley City. They have field services en route, but have not provided us an ETA at this time. We will update with information as it is provided to us by UTOPIA.