We are aware of an issue affecting XMission Fiber customers in West Valley City.
UTOPIA has a technician en route to assess the situation. We will provide additional information as it becomes available. Thank you for your patience.
UPDATE, 9:41pm -- UTOPIA has confirmed this is due to a fiber cut, and repairs are expected to take some time. Current ETA is 8am on Saturday, January 24th.
UPDATE, 01/24/2026 8:26 AM -- UTOPIA has updated the ETA to 4pm on Saturday, January 24th
UPDATE, 01/24/2026 7:00 PM -- UTOPIA has updated the ETA to 10pm on Saturday, January 24th
UPDATE, 01/24/2026 9:00 PM -- UTOPIA has updated the ETR to 11PM on Saturday, January 24th
UPDATE, 01/24/2026 10:00 PM -- We have received an update that most residents should be back online. Field services is completing repairs. ETR is still 11PM for completing the repairs.
UPDATE, 01/24/2026 11:00 PM -- The outage has been resolved. All services have been restored. The fiber damage has been repaired.