@XMissionStatus on Twitter

19th May 2021

West Point UTOPIA Outage in West Point

Outage in West Point. Techs in route. No ETA.

UPDATE Outage is due to "major fiber damage" and ETA is now 3:00 AM on 5/20

UPDATE 4:50PM Fiber crews are about 1 hour from having fiber ready to splice. The majority of customers should be up around 7:30PM. New ETR 12:00AM for all work to be completed