UTOPIA Network Outage Notification for 06/08/25 - Footprint(s) MU020
DESCRIPTION: UTOPIA has been alerted to an outage in the MU020 footprint(s) in Murray, UT. Field Services are in transit to the site. There are 85 residential customers affected.
START TIME: 07:23
---UPDATE---
UTOPIA Network Outage Resolution - 06/08/25 - Footprint(s) MU020 in Murray, UT.
RESOLVED: The outage has been resolved. All services have been restored.
Fiber cut possibly cause by Rodent followed by Redundancy failure
RESOLUTION TIME: 10:54