@XMissionStatus on Twitter

14th March 2025

Southern Ute Fiber Emergency Maintenance for Soutern Ute / Bonfire Fiber in Colorado

UPDATE: RESOLVED. 14 Mar 2025 3:51 p.m. MDT

Southern Ute Reservations residents, please watch email for a forthcoming announcement with outage details and a Service Outage Credit early next week.


Our monitoring systems have indicated our connection to Bonfire Fiber in Colorado is currently experiencing an outage. Our network team is investigating the cause

UPDATE 3:00 PM MDT: this outage is caused by a Lumen transport circuit in Northern Colorado. We are still awaiting full diagnosis and repair. As of this time there remains no ETR.