UPDATE 2: No current ETR.
UPDATE: Current ETR: 12:00 PM MT
UTOPIA is repairing a fiber cut which resulted in loss of connection for ~60 of our customers in West Valley City, including our customers located at Milburn Manor Estates.
UTOPIA Network Outage Resolution - 11/6/2024 - Footprint(s) WV027 in West Valley City, UT.
RESOLVED: The outage has been resolved. All services have been restored. Fiber dmg
RESOLUTION TIME: 4:00 PM