@XMissionStatus on Twitter

5th March 2024

Zimbra Hosted Email Zimbra Errors

UPDATE (RESOLVED): All Zimbra webmail services should be working for customers on the affected server

One of our Zimbra servers is currently having issues loading for customers. Our mail team is currently working on a fix, but at the present time we have no ETA. We'll update as updates are received

UPDATE: Some services within the Zimbra webmail portal may still be unavailable for those hosted on the affected server while it is being repaired. Current ETA 3-4 AM MT.