@XMissionStatus on Twitter

26th December 2023

XMission Emergency Scheduled Maintenance - resolved, scheduled 4 months ago

To improve performance and security on our datacenter network, XMission will be performing emergency scheduled maintenance on our datacenter access switches on Friday the 29th. Maintenance will begin on Friday the 29th at 00:05 AM MST and end by 6:00 AM MST. During this maintenance window our network admins will be upgrading the firmware on our datacenter access switches. Our network admins will strive to minimize downtime as much as possible, but colocation customers can expect service interruptions lasting around 15-45 minutes during this maintenance window.

Customers with VoIP services will also see their service impacted for 15-45 minutes during this time.

Update: Complications with final switch is extending maintenance window. New ETA 8am

Update: Complications resolved. Service should be active