@XMissionStatus on Twitter

25th June 2023

Bozeman Outage

We have identified an issue with some of our equipment affecting some Yellowstone Fiber customers. This is preventing users from accessing certain websites and services. This issue should be resolved within the hour.

UPDATE: We are still working on routing issues. We thank you for your patience. While most sites should be working, there are still a few sites that are having trouble. If you have IPv6 turned on, please disable that for the time being while we troubleshoot this further. Thank you again for your patience.

UPDATE 2: We are waiting to hear from our upstream provider to further resolve some of the issues being reported in.

UPDATE 3 Our primary upstream provider has confirmed they've finished repairs. We will now be working on moving our connection back to them and return to normal routing. YSF customers WILL notice a disruption in service while this happens.

Issue Fixed: The issues surrounding our customers in Bozeman have been resolved. If you continue to experience any issues please feel free to reach out to our support and we will be happy to assist you further. Thank you again for your patience while we worked on this together.