@XMissionStatus on Twitter

12th May 2023

XMission DNS Issues

XMission is experiencing a DNS issue and actively investigating. This problem can cause websites to fail to load and create the appearance of an Internet outage. Most XMission services are impacted. No ETA but we're all hands on deck and expect a fairly quick resolution.

Issue resolved 11:45 AM

UPDATE 1:16 PM

Incident reopened as some resolution is again unstable. Mitigations are being implemented.

UPDATE 3:50 PM

The issue is a massive DDOS to our DNS infrastructure which has been particularly difficult to fully quell. Customers should be able to use alternative DNS servers (ie 1.1.1.1 or 8.8.8.8) in their network configs as a work around.

UPDATE 6:15 PM MDT

XMission believes this issue is resolved.