@XMissionStatus on Twitter

8th June 2022

West Valley City West Valley Outage

No ETA yet

Resolved, Breaker in cabinet was tripped with UTOPIA node

RESOLVED: The outage has been resolved. All services have been restored. The breaker tripped in the cabinet. RESOLUTION TIME: 6:45 a.m.