@XMissionStatus on Bluesky

6th April 2026

Partial outage in Lehi - Damaged Fiber Line

UPDATE: We have received a notification that the partial outage on the Lehi City fiber network has been resolved.

Partial outage in Lehi, currently under investigation.

UPDATE at 11:45 AM A segment of the Lehi City Fiber Network is currently experiencing an outage affecting customers near Great Plains Way and Bull Hollow Way, cause by a damaged fiber line. Crews are actively working on repairing the damage at this time.