UPDATE: 08/06/2026 07:56 PM MDT - Fiber repair is complete. Service has been restored.
UPDATE: 5:00 PM
UTOPIA has let us know the ETA for this is 10PM
UPDATE: 11:10 am
This appears to be a fiber cut. UTOPIA has a field service technician in route to locate the damage. No ETR at this time.
We have been alerted to an outage affecting customers in Woodland Hills
ETA: 08/06/2026 10 PM
START TIME: 08/06/2026 09:57 AM MDT