@XMissionStatus on Bluesky

16th July 2026

Colocation Colocation Power Incident

We are aware of issues affecting our colocation customers, RMP has reported an outage in the area and they are currently investigating. We experienced a bump in power that may have triggered a power loss to your connection. If you do not have power-on-loss enabled, your server may need to be powered on.

We are currently running on generator power, we do not have an ETA at this time

Update: We are aware of an outage that affected our A-leg of power in the data center. Power is restored but we are on generators and are awaiting rocky mountain power to resolve the outage.

Update: Colocation is back to utility power