@XMissionStatus on Bluesky

12th July 2026

Tremonton UTOPIA Outage TR002

UPDATES: 07/13/2026 04:14 AM MDT - Ticket resolved 07/13/2026 04:13 AM MDT - Engineering replaced the fan. The switch is back up and service is restored.

UPDATES: 07/13/2026 02:22 AM MDT - Engineering has determined that the switch went down due to a failed fan tray. Field services is bringing up a replacement from Midvale. The current ETR is 5:00 a.m.

UPDATES: 07/12/2026 11:55 PM MDT - The outage is due to switch failure. Engineering is heading up to the cabinet. No current ETR.

DESCRIPTION: UTOPIA Network Outage TR002-ADS-2001 is down. Field services is heading out to the cabinet.
CATEGORY:

START TIME: 07/12/2026 09:30 PM MDT END TIME:

SCOPE OF IMPACT: Customers affected may be without service.

VERIFIED BUSINESS/ENTERPRISE CUSTOMERS: 14 VERIFIED RESIDENTIAL CUSTOMERS: 102